menu

Questions & Answers

trouble with libc6 and libc6-dev versions

I wanted to install gcc compiler for Golang on Linux (Debian 11) When trying to install:

sudo apt-get install golang gcc libgl1-mesa-dev xorg-dev

Errors:

The following packages have unmet dependencies:
 libc6-dev : Depends: libc6 (= 2.31-13+deb11u5) но 2.35-3 must be installed
             Depends: libc-dev-bin (= 2.31-13+deb11u5)
E: Unable to fix errors: you have broken packages.

sudo apt-cache policy libc6 libc6-dev

libc6:
  Installed: 2.35-3
  Candidate:   2.35-3
  Version table:
 *** 2.35-3 100
        100 /var/lib/dpkg/status
     2.31-13+deb11u5 500

libc6-dev:
  Installed: (absent)
  Candidate:   2.31-13+deb11u5
  Version table:
     2.31-13+deb11u5 500

What I tried and it didn't help:

sudo apt install -f
sudo dpkg --configure -a
sudo apt update && sudo apt upgrade
sudo apt install -t bullseye-backports libc6
sudo apt install -t bullseye-backports libc6-dev
sudo apt install -t bullseye-backports xorg-dev
sudo apt install libc6-dev=2.31-13+deb11u5
sudo apt install libc6-dev=2.35-3
sudo apt install -t bullseye-backports libc6-dev=2.35-3
sudo apt install libc6-dev=2.35-3
sudo apt install libc6=2.31-13+deb11u5
sudo apt install -t bullseye-backports libc6=2.31-13+deb11u5
Comments:
2023-01-19 23:52:18
Please write your question in English, as Stack Overflow is an English only site.. There are other versions of Stack Overflow in Português, Español, русский, and 日本語.
2023-01-19 23:52:18
I’m voting to close this question because Stack Overflow is an English only site: meta.stackexchange.com/q/13676
2023-01-19 23:52:18
already translated for you
Answers(0) :